windows服务器iis7.5安装多个php版本切换设置

因为某个网站程序的配置是在php5.3上面运行的,不兼容我现在的php5.5.所以就只能再安装个5.3的了。

在安装过程中,忘记截图了。。。就直接写吧。

准备工作:

1:php版本,这个根据自己需要的,自己去下载吧,我提供个5.3,64位的链接。

php版本要下载nts,后缀是zip格式的,非线程安全版本。

链接: http://pan.baidu.com/s/1o623i2m 密码: n6zw

官方的下载链接:http://windows.php.net/download/

2:下载PHP Manager工具

官网下载:http://phpmanager.codeplex.com/releases/view/69115

我用的64位链接:链接: http://pan.baidu.com/s/115DWM 密码: yxcq

3:Visual C++ 2008 这个可能有的服务器里面已经安装了,如果没有安装就需要再安装这个。

32位X86官网下载地址:http://www.microsoft.com/zh-cn/download/details.aspx?id=29

64位X64官网下载地址:http://www.microsoft.com/zh-cn/download/details.aspx?id=15336

 

开始安装:

1:把下载好的php放到网站目录,

windows服务器iis7.5安装多个php版本切换设置

2:安装PHP Manager

按照流程安装好就可以了,然后到iis界面去设置。

到你需要切换网站php版本的那个站点去,打开PHP Manager。

windows服务器iis7.5安装多个php版本切换设置

进入PHP Manager之后,先点击Register New PHP Version

windows服务器iis7.5安装多个php版本切换设置

在弹出的对话框中选择文件,找到你php目录。

windows服务器iis7.5安装多个php版本切换设置

选择php目录下的php-cgi.exe文件。

windows服务器iis7.5安装多个php版本切换设置

选择确定好之后,按照上面的流程再来一次,这次就选择另外一个版本的php-cgi文件。假如第一次是php5.3版本,那这次就添加php5.5版本的。

现在就是切换版本了,点击Change PHP version进行php版本的选择。

windows服务器iis7.5安装多个php版本切换设置

在弹出的对话框中选择你需要的版本就可以了。

windows服务器iis7.5安装多个php版本切换设置

现在就去看看你网站的配置是不是换了,如果出现了500错误,错误代码为0x800736b1

那就需要安装vc 2008的库了,安装这个就不说了。直接下载安装就可以了。

 

 

 

 

你可能喜欢